Minecraft Server is 1.12.2 – 1.13 compatible!

Minecraft Server is 1.12.2 – 1.13 compatible!

You can now play on Wombathaven using either 1.12.2 or 1.13! Getting a complete 1.13 server is in the works but it will be open soon!

Leave a Reply

Your email address will not be published. Required fields are marked *